Monday, 22 September 2014

Office 365 #11: Technical stuff – software required by Office 365

[image%255B3%255D.png]
Office 365 requires the following software:
- The current or immediately prior version of Internet Explorer, or the latest release of Chrome, Firefox or Safari.
- Any version of Microsoft Office in mainstream support.

Google Chrome
Latest version can perform all browser-related tasks

Firefox
Latest version can perform almost all browser-related tasks

Safari
Latest version can perform almost all browser-related tasks

Mobile Devices
Not included

Internet Explorer 10
Dependent on Operating System - must have Windows 7 or 8
Windows server 2012, 2008 and Windows 7
32-bit version can be used for all Office 365 tasks
64-bit version can be used for almost all Office 365 tasks

Internet Explorer 9
32-bit version can be used for almost all Office 365 tasks
64-bit version can be used for most Office 365 tasks

Internet Explorer 9
Windows 7 or Vista SP2

Internet Explorer 8
Windows 7, Vista SP2, XP-SP3 (32 bit), XP-SP2 (64-bit)

Internet Explorer 7
Not supported

Office 2010 Service Pack 1
(Service Pack 2 Recommended)

Windows 7, 8, Vista SP2, XP-SP3 (32-bit), XP-SP2 (64-bit)

Office 2007 with Service Pack 3
Windows 7, 8, Vista SP2, XP-SP3 (32-bit), XP-SP2 (64-bit)

Office for Mac 2011
with Service Pack 3

Mac OS X 10.6 or later

About Firewalls
To download and install some updates, Office 365 desktop setup needs to connect to the Microsoft Update service. However, in some networks, access to sites and services that are outside of your company’s firewall are blocked by the system administrator. If you cannot access the Microsoft Update service, you need to contact your system administrator for assistance.

No comments:

Post a Comment